Datasmith export plugins

Visual content courtesy of line-creative.uk

Some file formats cannot be directly imported into Unreal Engine using Datasmith, and instead the data must be converted into a file format that Datasmith understands. The plugins available for download on this page will enable your software to export the .udatasmith file format, which can then be imported into Unreal Engine using Datasmith. Many of these plugins are also compatible with Twinmotion.

Download the available installer file that matches the Unreal Engine or Twinmotion version you are using, exit your content creation software, and run the installer file to install the exporter plugin.

If you are installing these plugins on a computer that will not also have Unreal Engine installed, then you may first need to install some prerequisite dependencies for either 64-bit or 32-bit systems.

Autodesk 3ds Max Exporter

Supports 3ds Max/Design 2017 - 2025
For Unreal Engine 5.4
Last updated 6/4/2024

SketchUp Pro Exporter

Supports SketchUp Pro 2019 - 2024
For Unreal Engine 5.4 Windows
Last updated 6/4/2024

Autodesk Revit Exporter

Supports Revit 2018.3 - 2023
For Revit 2024+ functionality included in Revit
For Unreal Engine 5.2
Last updated 6/21/2023

Autodesk Navisworks Exporter

Supports Navisworks 2019 - 2024
Last updated 6/4/2024

Rhino Exporter

Supports Rhino 6 - 8
For Unreal Engine 5.4 Windows
Last updated 6/4/2024

Graphisoft ARCHICAD Exporter

Supports Archicad Full/Solo 23-24-25-26-27
For Unreal Engine 5.4 Windows
Last updated 6/4/2024

SOLIDWORKS Exporter

Supports SOLIDWORKS 2020 - 2024
For Unreal Engine 5.4
Last updated 6/4/2024

form•Z exporter

Supports form•Z pro, form•Z jr, form•Z Student Edition v9.0.6
For use with Unreal Engine

CDB Datasmith Exporter

Supports the Common Database (CDB) standard
For use with Unreal Engine

OpenFlight to Unreal

OpenFlight format (.flt) files into Unreal via Datasmith
For use with Unreal Engine

CET EXPORTER

Compatible with CET
For use with Unreal Engine

Allplan

Built in to Allplan 2023.1
For use with Unreal Engine

Modo (Beta)

Compatible with Modo 16 and above
For use with Unreal Engine